Mittwoch, 27. März 2019, 03:40 UTC+1

Sie sind nicht angemeldet.

  • Anmelden

Suchergebnisse

Suchergebnisse 1-20 von insgesamt 72.

Freitag, 28. August 2009, 13:21

Forenbeitrag von: »Alan«

TreeCreator - Erschaffe ganze Wälder mit nur wenigen Mausklicks!

@Grinseengel: Ich hab die Bilder durch JPGs ersetzt. Aber genau *das* passiert, wenn ich das mache - man sieht die Bilder nämlich gar nicht mehr xD Oder zumindest ich bei meinem Gerät hier sehe sie nicht. Das geht mir auch in diversen anderen Foren so, nicht nur hier, weshalb ich meine Bilder normalerweise als .bmp hochlade, da dieses Format die wenigsten Probleme macht, wenn man es direkt einbinden will. Die Links zu den Bildern stehen jedenfalls dabei, die sollten bei allen Leuten funktioniere...

Freitag, 28. August 2009, 11:08

Forenbeitrag von: »Alan«

TreeCreator - Erschaffe ganze Wälder mit nur wenigen Mausklicks!

@Grinseengel: Ja, das ist ohne Weiteres möglich. Du musst lediglich die gewünschten Baum-Modelle in den Ordner "My Input Files" kopieren und dann in "tcmain.c" in den Zeilen 30 und 31 die Standard-Baum-Modelle (durch den Namen angegeben) durch die Namen deiner Baum-Modelle ersetzen. Die einzige Beschränkung, die momentan besteht, ist die Limitierung auf 2 unterschiedliche Baum-Modelle. Aber wer ein klein wenig Ahnung von lite-c hat, wird auch problemlos 5 oder mehr verschiedene Modelle nutzen kö...

Donnerstag, 27. August 2009, 22:47

Forenbeitrag von: »Alan«

TreeCreator - Erschaffe ganze Wälder mit nur wenigen Mausklicks!

Hallo zusammen, ich wollte ja schon seit Längerem mal etwas zur Community beitragen, was ein jeder halbwegs gut für sein Projekt gebrauchen kann. Deshalb habe ich mich in den vergangenen Wochen intensiv mit einem Problem auseinander gesetzt, welches mir schon seit langer Zeit im Kopf herum spukt. Wie kann man am Besten einen Wald erstellen? Die eine Variante ist natürlich, alle Bäume von Hand zu platzieren - aber da fällt einem vorher die Hand ab, bevor man da auch nur einen größeren Level "bewa...

Montag, 24. August 2009, 15:21

Forenbeitrag von: »Alan«

Suche bestimmtes Tutorial

Hallo Leute, ich habe mir mit Hilfe eines Tutorials das Wissen angeeignet, wie man ein Low-Poly-Model eines Menschen mit MED erstellt und das klappt soweit auch ganz gut. Allerdings endet das Tutorial mit der Erstellung des Meshes auch schon wieder. Was ich jetzt bräuchte wären Tutorials zu folgenden Themen: a) Erstellen einer Textur für das Modell sowie das Texturieren von komplexeren Objekten (es muss nicht ein menschlicher Körper im speziellen sein, aber ein wenig komplexer als ein Würfel dar...

Montag, 24. August 2009, 15:04

Forenbeitrag von: »Alan«

Neue Internetpräsenz der 3dgs-Hobbyschmiede

Hi, bin durch Zufall mal wieder auf die Hauptseite gewechselt (die Forum-Adresse ist in meinen Favoriten deshalb gelange ich immer direkt hierher) und ich muss sagen: WOW, ganz großen Respekt von meiner Seite her, sieht toll aus, dabei aber weder gekünstelt noch übertrieben, zumal die Übersicht im Vergleich zu vorher nun deutlich besser ist - eine rundum gelungene Seite würde ich sagen! Bleibt noch zu hoffen, dass sich der Inhalt in der nächsten Zeit stark mehren wird... Tutorials etc. meine ich...

Freitag, 14. August 2009, 22:55

Forenbeitrag von: »Alan«

Straßen und Wege in einem Terrain

@nico: sieht nett aus, wirklich! Wie bist du vorgegangen?

Freitag, 14. August 2009, 11:30

Forenbeitrag von: »Alan«

Straßen und Wege in einem Terrain

Hi, du meinst also, ich soll zuerst mein Terrain erstellen (ohne die Straßen), dann als Heightmap exportieren und in einem Bildbearbeitungsprogrammd die Straßen mit Farbverläufen nachträglich hinzufügen? Hm, in der Tat keine Schlechte Idee, das werde ich mal versuchen Übrigens: ja es ist in MED möglich, ein Modell in ein Terrain umzuwandeln. Allerdings muss das Gitter in Bezug auf die X- und Y-Positionen der Vertices perfekt passen, wenn da auch nur ein Vertex leicht in X- oder Y-Position versch...

Donnerstag, 13. August 2009, 20:35

Forenbeitrag von: »Alan«

Straßen und Wege in einem Terrain

Hallo zusammen, nachdem ich mein Problem mit dem Mulitex-Shader in den Griff bekommen habe (endlich!) kann ich jetzt so richtig mit der Terrainerstellung anfangen. Ich habe hier ein Terrain mit sehr viel Gebirge darauf und nur wenig Flachland. Ich möchte, dass eine Straße vom flachen Teil auf ein Plateau im Gebirge führt. Die Straße selbst soll dabei in Serpentinen verlaufen, die aber in Richtung Tal *nicht* abschüssig sein sollen - also quasi eine waagrechte Straße auf einem steilen Hang, wie m...

Donnerstag, 13. August 2009, 19:50

Forenbeitrag von: »Alan«

Problem mit Terrain

Hi, hatte das Problem auch einmal. Höchstwahrscheinlich liegt es daran, dass deine Textur einen Alphakanal hat bzw. 32bit Farbtiefe. Schraube die Farbtiefe deiner Textur herunter (das Bilbearbeitungsprogramm deines Vertrauens hilft dir dabei) und das Problem sollte sich von selbst lösen, gegebenenfalls kannst du in MED die Textur neu importieren und die alte damit ersetzen. Gruß, Alan

Donnerstag, 13. August 2009, 17:44

Forenbeitrag von: »Alan«

Problem mit Standard-Multitex-Shader für Terrains

Hat wirklich niemand eine Idee, woran es liegen könnte? Traurig genug dass dem 3DGS keine Beispiele mitgeliefert werden, in denen die einzelnen Shader zur Anwendung kommen.... EDIT: Ich hab's - es funktioniert endlich *g* Wisst ihr wo das Problem lag? Ich kann es selber kaum glauben - in der BENENNUNG DER SKINS! Med benennt die Skins automatisch mit "Skin 0" "Skin 1" "Skin 2" und "Skin 3", der Shader erwartet aber "Skin 1" bis "Skin 4" - also alle vier umbenannt und das Ergebnis sieht prächtig a...

Sonntag, 9. August 2009, 09:40

Forenbeitrag von: »Alan«

Problem mit Standard-Multitex-Shader für Terrains

Hi, keinerlei Fehlermeldungen, weder beim Compilieren noch beim Starten. Es handelt sich um den Standard-Shader, der mit 3DGS 7 Commercial ausgeliefert wird. Er heißt "terraintex3" und wird auch im Handbuch beschrieben. Im Quelltext des Shaders selbst sind Kommentare eingefügt, die eigentlich unmissverständlich erklären, auf welchem Skin des Terrains sich welche Grafik befinden muss - und daran habe ich mich gehalten. Nur leider sieht das Ergebnis nicht so aus wie es soll.... ' Wenn jemand es hi...

Samstag, 8. August 2009, 17:21

Forenbeitrag von: »Alan«

Problem mit Standard-Multitex-Shader für Terrains

Hallo zusammen, nachdem ich jetzt einige Tage Zeit hatte, habe ich mir das Grundgerüst eines recht einfachen RPGs zusammengebastelt und soweit ist alles gut verlaufen. Allerdings will der Terrain-Multitextur-Shader nicht so recht, hier ein Bild: http://www.letsshareit.net/files/5/screenshot_rpg.bmp Ihr seht was ich meine nehme ich an... ich habe *eigentlich* eine Gras- und eine Felstextur angegeben, allerdings fördert der Shader stattdessen nur grüne und graue Flächen zutage. Das bedeutet einers...

Sonntag, 19. Juli 2009, 11:39

Forenbeitrag von: »Alan«

Lite-C Code aus externen Dateien ausführen...?

Zitat von »Mac« Übrigens wäre so ein Interpreter unglaublich Lahm da er wahrscheinlich nicht am Anfang den "Code" parst und zerlegt, sondern in Echtzeit mit if Abfragen durchspringt... Erm, okay, ich muss zugeben - so hätte ich es gemacht xD Weil ich sonst nicht gewusst hätte, wie. Aber ich werde mein Problem auf jeden Fall mit den .c-Dateien angehen und dann die darin enthaltenen Funktionen aufrufen. Eine weitere Frage zu diesem Thema hätte ich noch. Es gibt ja in lite-C nach wie vor keine "...

Samstag, 18. Juli 2009, 17:26

Forenbeitrag von: »Alan«

Lite-C Code aus externen Dateien ausführen...?

Naja, okay - aber in einer .c-Datei müsste das funktionieren nehme ich an

Freitag, 17. Juli 2009, 20:56

Forenbeitrag von: »Alan«

Lite-C Code aus externen Dateien ausführen...?

Hm, aber ich könnte - wie du sagst - die Codezeilen, die ausgelagert werden sollen, einfach als Funktionen in einer .h-Datei definieren, die dann eingebunden wird, richtig? Das wär auch eine Möglichkeit Danke für den Hinweis! Alan

Freitag, 17. Juli 2009, 11:22

Forenbeitrag von: »Alan«

Lite-C Code aus externen Dateien ausführen...?

Hallo zusammen, nachdem ich jetzt wieder einige Zeit inaktiv war, habe ich mir jetzt das 3DGS Commercial zugelegt und will jetzt mit Lite-C durchstarten. Gleich zu Beginn habe ich da eine Frage. Ich suche eine Funktion, die in etwa so aussieht wie diese hier: Quellcode 1 2 PSEUDO-Code execute_file(path of STRING*) Also quasi einen Befehl, der das Programm anweist, an dieser Stelle mit den Codezeilen in der durch "path" angegebenen Datei fortzufahren. Die externe Datei enthält dabei keine Aktione...

Donnerstag, 9. Juli 2009, 10:56

Forenbeitrag von: »Alan«

3DGS macht Probleme unter Vista 64

@Lanzet 3: Hat leider auch nichts gebracht. Wenn ich die von dir genannten Schritte ausführe, führt das nur dazu, dass ich anstatt der weißen Fläche einfach nur den Rahmen des Fensters sehe - ohne Inhalt. MED friert nach wie vor beim Starten ein. Um Missverständnissen vorzubeugen: Ich sehe nur die Titelleiste sowie die Aktionsleiste mit "Datei/Bearbeiten" etc. Darunter ist ALLES weiß. Keine Abgrenzungen zwischen 2D- und 3D-Fenstern, keine Aktionsknöpfe, GAR NICHTS. Einfach nur eine weiße Fläche.

Donnerstag, 9. Juli 2009, 10:41

Forenbeitrag von: »Alan«

3DGS macht Probleme unter Vista 64

Das mit den Bibliotheken wäre ja weniger schlimm - das ist höchstens lästig, aber kein echtes Problem in diesem Sinne. Das eigentliche Problem ist, dass MED bei mir nicht läuft... bei dir ohne Probleme?

Donnerstag, 9. Juli 2009, 09:35

Forenbeitrag von: »Alan«

3DGS macht Probleme unter Vista 64

Hallo zusammen, ich war jetzt länger nicht mehr aktiv aber das hat seinen Grund - ich war die ewigen Bugs im 3DGS leid, die man nur durch Update beheben kann (was mir durch die Sybex-Version verwehrt blieb...). Jetzt habe ich mir einen brandneuen PC gekauft und quasi "zur Feier des Tages" noch die Commercial Edition von 3DGS7 obendrauf. Mein neues Betriebssystem ist ein 64-Bit-Vista (bedingt durch mehr als 3GB Arbeitsspeicher) und da treten einige Probleme auf, die ich euch im Folgenden kurz sch...